aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/restricted/boost/atomic/CMakeLists.txt
diff options
context:
space:
mode:
authorthegeorg <thegeorg@yandex-team.com>2022-12-15 19:25:15 +0300
committerthegeorg <thegeorg@yandex-team.com>2022-12-15 19:25:15 +0300
commit0c31d97afd7858af5f8f858c8addf91655ca9ccc (patch)
tree4d8a246db168f7beaafcd06d486c034115c2123d /contrib/restricted/boost/atomic/CMakeLists.txt
parentd1d5f5e00df0dd6efc00880dd8283477fc643aaf (diff)
downloadydb-0c31d97afd7858af5f8f858c8addf91655ca9ccc.tar.gz
Sync linux-headers instead of using system ones
Diffstat (limited to 'contrib/restricted/boost/atomic/CMakeLists.txt')
-rw-r--r--contrib/restricted/boost/atomic/CMakeLists.txt35
1 files changed, 7 insertions, 28 deletions
diff --git a/contrib/restricted/boost/atomic/CMakeLists.txt b/contrib/restricted/boost/atomic/CMakeLists.txt
index 5b62fa5258..3e0811fb22 100644
--- a/contrib/restricted/boost/atomic/CMakeLists.txt
+++ b/contrib/restricted/boost/atomic/CMakeLists.txt
@@ -6,31 +6,10 @@
# original buildsystem will not be accepted.
-
-add_library(restricted-boost-atomic)
-target_compile_options(restricted-boost-atomic PRIVATE
- -DBOOST_ATOMIC_SOURCE
- -Wno-everything
-)
-target_include_directories(restricted-boost-atomic PUBLIC
- ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/atomic/include
-)
-target_include_directories(restricted-boost-atomic PRIVATE
- ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/winapi/include
- ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/atomic/src
-)
-target_link_libraries(restricted-boost-atomic PUBLIC
- contrib-libs-cxxsupp
- restricted-boost-align
- restricted-boost-assert
- restricted-boost-config
- restricted-boost-predef
- restricted-boost-preprocessor
- restricted-boost-static_assert
- restricted-boost-type_traits
-)
-target_sources(restricted-boost-atomic PRIVATE
- ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/atomic/src/find_address_sse2.cpp
- ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/atomic/src/find_address_sse41.cpp
- ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/atomic/src/lock_pool.cpp
-)
+if (CMAKE_SYSTEM_PROCESSOR STREQUAL "aarch64" AND UNIX AND NOT APPLE AND NOT ANDROID)
+ include(CMakeLists.linux-aarch64.txt)
+elseif (APPLE)
+ include(CMakeLists.darwin.txt)
+elseif (CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64" AND UNIX AND NOT APPLE AND NOT ANDROID)
+ include(CMakeLists.linux.txt)
+endif()