aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/restricted/CMakeLists.txt
diff options
context:
space:
mode:
authorrobot-piglet <robot-piglet@yandex-team.com>2023-03-09 12:42:44 +0300
committerrobot-piglet <robot-piglet@yandex-team.com>2023-03-09 12:42:44 +0300
commit6324d075a5e80b6943b5de6b465b775050fe83df (patch)
treee02ce32e988042438f64df770a528164ac572879 /contrib/restricted/CMakeLists.txt
parent039e25e1597bec288de44e5061c1b84e195add08 (diff)
downloadydb-6324d075a5e80b6943b5de6b465b775050fe83df.tar.gz
Intermediate changes
Diffstat (limited to 'contrib/restricted/CMakeLists.txt')
-rw-r--r--contrib/restricted/CMakeLists.txt20
1 files changed, 9 insertions, 11 deletions
diff --git a/contrib/restricted/CMakeLists.txt b/contrib/restricted/CMakeLists.txt
index b5f18eb5e9..d90657116d 100644
--- a/contrib/restricted/CMakeLists.txt
+++ b/contrib/restricted/CMakeLists.txt
@@ -6,14 +6,12 @@
# original buildsystem will not be accepted.
-add_subdirectory(abseil-cpp)
-add_subdirectory(abseil-cpp-tstring)
-add_subdirectory(aws)
-add_subdirectory(boost)
-add_subdirectory(cityhash-1.0.2)
-add_subdirectory(dragonbox)
-add_subdirectory(fast_float)
-add_subdirectory(googletest)
-add_subdirectory(nlohmann_json)
-add_subdirectory(thrift)
-add_subdirectory(uriparser)
+if (CMAKE_SYSTEM_PROCESSOR STREQUAL "aarch64" AND UNIX AND NOT APPLE AND NOT ANDROID)
+ include(CMakeLists.linux-aarch64.txt)
+elseif (APPLE AND CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64")
+ include(CMakeLists.darwin-x86_64.txt)
+elseif (WIN32 AND CMAKE_SYSTEM_PROCESSOR STREQUAL "AMD64" AND NOT HAVE_CUDA)
+ include(CMakeLists.windows-x86_64.txt)
+elseif (CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64" AND UNIX AND NOT APPLE AND NOT ANDROID AND NOT HAVE_CUDA)
+ include(CMakeLists.linux-x86_64.txt)
+endif()