aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/libs/poco/CMakeLists.txt
diff options
context:
space:
mode:
authorrobot-piglet <robot-piglet@yandex-team.com>2023-03-09 12:42:44 +0300
committerrobot-piglet <robot-piglet@yandex-team.com>2023-03-09 12:42:44 +0300
commit6324d075a5e80b6943b5de6b465b775050fe83df (patch)
treee02ce32e988042438f64df770a528164ac572879 /contrib/libs/poco/CMakeLists.txt
parent039e25e1597bec288de44e5061c1b84e195add08 (diff)
downloadydb-6324d075a5e80b6943b5de6b465b775050fe83df.tar.gz
Intermediate changes
Diffstat (limited to 'contrib/libs/poco/CMakeLists.txt')
-rw-r--r--contrib/libs/poco/CMakeLists.txt16
1 files changed, 9 insertions, 7 deletions
diff --git a/contrib/libs/poco/CMakeLists.txt b/contrib/libs/poco/CMakeLists.txt
index 269a5757fc..d90657116d 100644
--- a/contrib/libs/poco/CMakeLists.txt
+++ b/contrib/libs/poco/CMakeLists.txt
@@ -6,10 +6,12 @@
# original buildsystem will not be accepted.
-add_subdirectory(Crypto)
-add_subdirectory(Foundation)
-add_subdirectory(JSON)
-add_subdirectory(Net)
-add_subdirectory(NetSSL_OpenSSL)
-add_subdirectory(Util)
-add_subdirectory(XML)
+if (CMAKE_SYSTEM_PROCESSOR STREQUAL "aarch64" AND UNIX AND NOT APPLE AND NOT ANDROID)
+ include(CMakeLists.linux-aarch64.txt)
+elseif (APPLE AND CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64")
+ include(CMakeLists.darwin-x86_64.txt)
+elseif (WIN32 AND CMAKE_SYSTEM_PROCESSOR STREQUAL "AMD64" AND NOT HAVE_CUDA)
+ include(CMakeLists.windows-x86_64.txt)
+elseif (CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64" AND UNIX AND NOT APPLE AND NOT ANDROID AND NOT HAVE_CUDA)
+ include(CMakeLists.linux-x86_64.txt)
+endif()