aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/libs/pfr/CMakeLists.txt
diff options
context:
space:
mode:
authoraozeritsky <aozeritsky@ydb.tech>2023-08-21 17:15:26 +0300
committeraozeritsky <aozeritsky@ydb.tech>2023-08-21 17:30:24 +0300
commit6128c83f475b712a95f262e363dd2d3681500a0e (patch)
treefb52e4fa7d0dccb6bc4e6ced2707e11bfaf2e4b3 /contrib/libs/pfr/CMakeLists.txt
parenteac8ca1f552726198b4d7a21fcdecf8954339262 (diff)
downloadydb-6128c83f475b712a95f262e363dd2d3681500a0e.tar.gz
Add yt into autobuild
Diffstat (limited to 'contrib/libs/pfr/CMakeLists.txt')
-rw-r--r--contrib/libs/pfr/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/contrib/libs/pfr/CMakeLists.txt b/contrib/libs/pfr/CMakeLists.txt
new file mode 100644
index 0000000000..4d48dcdee6
--- /dev/null
+++ b/contrib/libs/pfr/CMakeLists.txt
@@ -0,0 +1,13 @@
+
+# This file was generated by the build system used internally in the Yandex monorepo.
+# Only simple modifications are allowed (adding source-files to targets, adding simple properties
+# like target_include_directories). These modifications will be ported to original
+# ya.make files by maintainers. Any complex modifications which can't be ported back to the
+# original buildsystem will not be accepted.
+
+
+if (CMAKE_SYSTEM_NAME STREQUAL "Linux" AND CMAKE_SYSTEM_PROCESSOR STREQUAL "aarch64" AND NOT HAVE_CUDA)
+ include(CMakeLists.linux-aarch64.txt)
+elseif (CMAKE_SYSTEM_NAME STREQUAL "Linux" AND CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64" AND NOT HAVE_CUDA)
+ include(CMakeLists.linux-x86_64.txt)
+endif()