aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/libs/pcre/pcre32/CMakeLists.txt
diff options
context:
space:
mode:
authorthegeorg <thegeorg@yandex-team.com>2022-12-15 19:25:15 +0300
committerthegeorg <thegeorg@yandex-team.com>2022-12-15 19:25:15 +0300
commit0c31d97afd7858af5f8f858c8addf91655ca9ccc (patch)
tree4d8a246db168f7beaafcd06d486c034115c2123d /contrib/libs/pcre/pcre32/CMakeLists.txt
parentd1d5f5e00df0dd6efc00880dd8283477fc643aaf (diff)
downloadydb-0c31d97afd7858af5f8f858c8addf91655ca9ccc.tar.gz
Sync linux-headers instead of using system ones
Diffstat (limited to 'contrib/libs/pcre/pcre32/CMakeLists.txt')
-rw-r--r--contrib/libs/pcre/pcre32/CMakeLists.txt41
1 files changed, 7 insertions, 34 deletions
diff --git a/contrib/libs/pcre/pcre32/CMakeLists.txt b/contrib/libs/pcre/pcre32/CMakeLists.txt
index 9be3912ae8..3e0811fb22 100644
--- a/contrib/libs/pcre/pcre32/CMakeLists.txt
+++ b/contrib/libs/pcre/pcre32/CMakeLists.txt
@@ -6,37 +6,10 @@
# original buildsystem will not be accepted.
-
-add_library(libs-pcre-pcre32)
-target_compile_options(libs-pcre-pcre32 PRIVATE
- -DHAVE_CONFIG_H
- -Wno-everything
-)
-target_include_directories(libs-pcre-pcre32 PRIVATE
- ${CMAKE_SOURCE_DIR}/contrib/libs/pcre
-)
-target_sources(libs-pcre-pcre32 PRIVATE
- ${CMAKE_SOURCE_DIR}/contrib/libs/pcre/pcre32_byte_order.c
- ${CMAKE_SOURCE_DIR}/contrib/libs/pcre/pcre32_chartables.c
- ${CMAKE_SOURCE_DIR}/contrib/libs/pcre/pcre32_compile.c
- ${CMAKE_SOURCE_DIR}/contrib/libs/pcre/pcre32_config.c
- ${CMAKE_SOURCE_DIR}/contrib/libs/pcre/pcre32_dfa_exec.c
- ${CMAKE_SOURCE_DIR}/contrib/libs/pcre/pcre32_exec.c
- ${CMAKE_SOURCE_DIR}/contrib/libs/pcre/pcre32_fullinfo.c
- ${CMAKE_SOURCE_DIR}/contrib/libs/pcre/pcre32_get.c
- ${CMAKE_SOURCE_DIR}/contrib/libs/pcre/pcre32_globals.c
- ${CMAKE_SOURCE_DIR}/contrib/libs/pcre/pcre32_jit_compile.c
- ${CMAKE_SOURCE_DIR}/contrib/libs/pcre/pcre32_maketables.c
- ${CMAKE_SOURCE_DIR}/contrib/libs/pcre/pcre32_newline.c
- ${CMAKE_SOURCE_DIR}/contrib/libs/pcre/pcre32_ord2utf32.c
- ${CMAKE_SOURCE_DIR}/contrib/libs/pcre/pcre32_refcount.c
- ${CMAKE_SOURCE_DIR}/contrib/libs/pcre/pcre32_string_utils.c
- ${CMAKE_SOURCE_DIR}/contrib/libs/pcre/pcre32_study.c
- ${CMAKE_SOURCE_DIR}/contrib/libs/pcre/pcre32_tables.c
- ${CMAKE_SOURCE_DIR}/contrib/libs/pcre/pcre32_ucd.c
- ${CMAKE_SOURCE_DIR}/contrib/libs/pcre/pcre32_utf32_utils.c
- ${CMAKE_SOURCE_DIR}/contrib/libs/pcre/pcre32_valid_utf32.c
- ${CMAKE_SOURCE_DIR}/contrib/libs/pcre/pcre32_version.c
- ${CMAKE_SOURCE_DIR}/contrib/libs/pcre/pcre32_xclass.c
- ${CMAKE_SOURCE_DIR}/contrib/libs/pcre/pcre_chartables.c
-)
+if (CMAKE_SYSTEM_PROCESSOR STREQUAL "aarch64" AND UNIX AND NOT APPLE AND NOT ANDROID)
+ include(CMakeLists.linux-aarch64.txt)
+elseif (APPLE)
+ include(CMakeLists.darwin.txt)
+elseif (CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64" AND UNIX AND NOT APPLE AND NOT ANDROID)
+ include(CMakeLists.linux.txt)
+endif()