aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/libs/linux-headers/CMakeLists.txt
diff options
context:
space:
mode:
authorrobot-ya-builder <robot-ya-builder@yandex-team.com>2023-03-17 19:38:27 +0300
committerrobot-ya-builder <robot-ya-builder@yandex-team.com>2023-03-17 19:38:27 +0300
commit26147c4e01ae75f397d4dd999da238bf2c61c851 (patch)
tree873a652bca08f38df296c77422b40fd404f0481e /contrib/libs/linux-headers/CMakeLists.txt
parent08f6d0d9bb84f493c5dfd3c0d1568445faa26d85 (diff)
downloadydb-26147c4e01ae75f397d4dd999da238bf2c61c851.tar.gz
External build system generator release 21
Update tools: yexport
Diffstat (limited to 'contrib/libs/linux-headers/CMakeLists.txt')
-rw-r--r--contrib/libs/linux-headers/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/contrib/libs/linux-headers/CMakeLists.txt b/contrib/libs/linux-headers/CMakeLists.txt
index 4349073206..e4e7609ebf 100644
--- a/contrib/libs/linux-headers/CMakeLists.txt
+++ b/contrib/libs/linux-headers/CMakeLists.txt
@@ -6,8 +6,8 @@
# original buildsystem will not be accepted.
-if (CMAKE_SYSTEM_PROCESSOR STREQUAL "aarch64" AND UNIX AND NOT APPLE AND NOT ANDROID)
+if (CMAKE_SYSTEM_NAME STREQUAL "Linux" AND CMAKE_SYSTEM_PROCESSOR STREQUAL "aarch64")
include(CMakeLists.linux-aarch64.txt)
-elseif (CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64" AND UNIX AND NOT APPLE AND NOT ANDROID AND NOT HAVE_CUDA)
+elseif (CMAKE_SYSTEM_NAME STREQUAL "Linux" AND CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64" AND NOT HAVE_CUDA)
include(CMakeLists.linux-x86_64.txt)
endif()