aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/libs/grpc/src/python/grpcio_channelz/setup.py
diff options
context:
space:
mode:
authorheretic <heretic@yandex-team.ru>2022-03-25 12:34:53 +0300
committerheretic <heretic@yandex-team.ru>2022-03-25 12:34:53 +0300
commita41f3739eed6fceb6f62056a7620d220958a47e7 (patch)
tree278103258b510cb4a96761ea79d6ccd397ca05a0 /contrib/libs/grpc/src/python/grpcio_channelz/setup.py
parent73d3613a82e5c217fcbe0ab8bbf8120c1ed1af55 (diff)
downloadydb-a41f3739eed6fceb6f62056a7620d220958a47e7.tar.gz
Update grpc to 1.43.2 DTCC-864
ref:50a492c335cda70f458797cf945e49fe739c2715
Diffstat (limited to 'contrib/libs/grpc/src/python/grpcio_channelz/setup.py')
-rw-r--r--contrib/libs/grpc/src/python/grpcio_channelz/setup.py5
1 files changed, 3 insertions, 2 deletions
diff --git a/contrib/libs/grpc/src/python/grpcio_channelz/setup.py b/contrib/libs/grpc/src/python/grpcio_channelz/setup.py
index 678b5ef13f..cec1ea2ee9 100644
--- a/contrib/libs/grpc/src/python/grpcio_channelz/setup.py
+++ b/contrib/libs/grpc/src/python/grpcio_channelz/setup.py
@@ -47,8 +47,6 @@ class _NoOpCommand(setuptools.Command):
CLASSIFIERS = [
'Development Status :: 5 - Production/Stable',
'Programming Language :: Python',
- 'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
@@ -56,6 +54,7 @@ CLASSIFIERS = [
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: 3.9',
+ 'Programming Language :: Python :: 3.10',
'License :: OSI Approved :: Apache Software License',
]
@@ -70,6 +69,7 @@ INSTALL_REQUIRES = (
try:
import channelz_commands as _channelz_commands
+
# we are in the build environment, otherwise the above import fails
SETUP_REQUIRES = ('grpcio-tools=={version}'.format(
version=grpc_version.VERSION),)
@@ -98,6 +98,7 @@ setuptools.setup(
url='https://grpc.io',
package_dir=PACKAGE_DIRECTORIES,
packages=setuptools.find_packages('.'),
+ python_requires='>=3.6',
install_requires=INSTALL_REQUIRES,
setup_requires=SETUP_REQUIRES,
cmdclass=COMMAND_CLASS)